Strange problem with Uridium - Warning: noob here!

Página 1/2
| 2

Por Shrapnel

Resident (38)

Imagen del Shrapnel

11-11-2014, 23:02

Hi everyone!

I've got a curious problem with the Uridium cart I bouth from Repro Factory and/or my MSX.
When I tried the game's ROM on blueMSX it was fast and nippy, but using the real cart on my NMS-8280 the game is horribly slow and literally crawls around. Crying
Any idea or suggestion?

Thanks in advance!

Login sesión o register para postear comentarios

Por ericb59

Paragon (1079)

Imagen del ericb59

12-11-2014, 07:13

hello,

first can you check the Difficulty level in the game menu is on Hard ?
(other levels are slowing down the scroll for beginners)

Por ARTRAG

Enlighted (6846)

Imagen del ARTRAG

12-11-2014, 09:16

Hi Sharpnel
a similar problem was reported on a modded Philips msx2 with modified vdp (it had a v9958 instead of the plain 9938).
The solution there was to use Toshiba mode. We didn't investigate any further as the hack on the machine was not reproducible, but I have no idea of what was wrong and why it Toshiba mode was solving the issue.

A few questions to try to investigate a bit more:
What is you cart number ?
Have you tried the cart on other machines?
Is your NMS-8280 modded in some way or plain and simple ?
Have you tried to play a bit in the menu with difficulty levels and with the VDP options?
Do you use the cart with other carts or extension plugged ?
In openmsx 0.11 the rom works on all the NMS-82XX I have (from 820 to 8255), but I didn't try the 8280 as I haven't a valid rom set for that machine.
It could be useful to find the roms for such a machine so to see if the problem can be reproduced... hint ... ;-)

Por Shrapnel

Resident (38)

Imagen del Shrapnel

12-11-2014, 11:47

ericb59 wrote:

hello,
first can you check the Difficulty level in the game menu is on Hard ?
(other levels are slowing down the scroll for beginners)

That's the first thing I did, but the game was very slow anyway.
But then something strange happened... I tried again yesterday and the game was far faster. Hard was more or less as fast as Normal in the 48K ROM.
Didn't change anything, didn't do anything... the game just ran faster. Tongue

Por ericb59

Paragon (1079)

Imagen del ericb59

12-11-2014, 11:52

The Normal scroll speed is "Hard" mode.
The difficulty level's names are not the same on the 48K Rom and on the Final Cartridge.

So, is the problem solve ?

Por Shrapnel

Resident (38)

Imagen del Shrapnel

12-11-2014, 11:54

ARTRAG wrote:

A few questions to try to investigate a bit more:
What is you cart number ?
Have you tried the cart on other machines?
Is your NMS-8280 modded in some way or plain and simple ?
Have you tried to play a bit in the menu with difficulty levels and with the VDP options?
It could be useful to find the roms for such a machine so to see if the problem can be reproduced... hint ... ;-)

My cart is #73, if memory serves, and I have no other machines handy to try it on. =(
My MSX2 is not modded and I played a lot with the settings, but the game stayed slow...

... until yesterday, that is. I tried the game again and it was going considerably faster, don't know why. =P
I'd say Hard mode is more or less as fast as Normal on the 48K ROM, which could be right since I know there are differences between the ROM and the cart. I didn't touch anything, I kept my 'standard' settings and the game was happily zipping around. =P
I'm starting to think there was something wrong with my machine, maybe it had a bad day, dunno. But I'm almost sure it's not the game, since the 'error' suddenly seemed to disappear. =P

I'm still curious about one thing, though: I have my MSX2 hooked to a CRT TV through it SCART socket and if I activate enhanced enemies they flicker quite a lot, while the instruction leaflet says it should only happen on LCDs. That's weird, isn't it? =)

About dumping the romset from the 8280, I have absolutely NO idea about how to do it. Any help? =)

PS
I'll give you further details via e-mail, since I just received a message from you. Yes, I'm one of the Italian buyers. =D

Por Shrapnel

Resident (38)

Imagen del Shrapnel

12-11-2014, 11:57

ericb59 wrote:

The Normal scroll speed is "Hard" mode.
The difficulty level's names are not the same on the 48K Rom and on the Final Cartridge.

Yep, as I stated in my next post, I thought that could be one of the differences in the cart version. =)

ericb59 wrote:

So, is the problem solve ?

It looks so, but I don't know why, lol! =D

Por ARTRAG

Enlighted (6846)

Imagen del ARTRAG

12-11-2014, 15:20

The problem could be due to the warming of the vdp affecting in turn the status register.
In this case you could try to see if the glitch appears after a while the system is turned on.
For sure the slowness is due to the vdp that is missing the line where the screen split occurs.

Por Shrapnel

Resident (38)

Imagen del Shrapnel

12-11-2014, 18:55

ARTRAG wrote:

The problem could be due to the warming of the vdp affecting in turn the status register.
In this case you could try to see if the glitch appears after a while the system is turned on.

If we're talking about the flickering enhanced sprites, it happens since the machine is turned on, even if it's been off and disconnected from mains for an entire night and day. =P

ARTRAG wrote:

For sure the slowness is due to the vdp that is missing the line where the screen split occurs.

Does this mean there's a problem with my MSX2 or could it just be a 'temporary' issue? As I said, I played yesterday and the game's speed seemed fine.
Thanks for taking your time to help, by the way! =)

Por ARTRAG

Enlighted (6846)

Imagen del ARTRAG

12-11-2014, 20:08

No I was telling about the slow down.
The flickering depends on the refresh rate of your crt.
There is no workaround for this, sorry

Por Shrapnel

Resident (38)

Imagen del Shrapnel

12-11-2014, 20:18

ARTRAG wrote:

The flickering depends on the refresh rate of your crt.
There is no workaround for this, sorry

No big deal, doesn't stop the game from being awesome anyway. =D

Página 1/2
| 2