F4/FMPAC Light Combo Board project

Página 19/19
12 | 13 | 14 | 15 | 16 | 17 | 18 |

Por alali.ahmed.t

Resident (52)

Imagen del alali.ahmed.t

19-05-2022, 18:41

Alexey wrote:

For Carnivore2 you can create a configuration entry to exclude FMPAC and only keep RAM and IDE for example. Use the C2MAN utility to create that entry. This way you can use the internal FMPAC. FM files are actually .bas files, so run them as normal basic files: run"file.fm"

The FMPAC BIOS is a combined one (internal + external). For the correct placement of the BIOS in the slot, you need to follow the instructions. If you use 27C256, then just write the "combined.rom" into the chip and use CS1 pin, but when using 27C512, you need to write the ROM file twice into the chip (make 64kb file by adding 32kb file to itself) and use the RD pin.

So, If I will use 27C512 I will have to connect to RD, but there is no RD on the mini slot 3.1 as per the schematic the pin 8 is CS1 and pin 6 is CS1/2. Which means I can not connect as per the picture you sent, right? or am I understanding differently?

In case I want to use 27C256, I assume that JP3 is not needed even though it is marked with a pin saying 27c256, right?

Por Wierzbowsky

Guardian (3443)

Imagen del Wierzbowsky

20-05-2022, 23:28

If you can't find the RD signal, just use CS1. But you will need to append the "internal.rom" 3 times to itself (to make it 64kb) for the 27C512 EPROM chip. Or just write the "combined.rom" into 27C256 EPROM.

Por alali.ahmed.t

Resident (52)

Imagen del alali.ahmed.t

21-05-2022, 03:30

Alexey wrote:

If you can't find the RD signal, just use CS1. But you will need to append the "internal.rom" 3 times to itself (to make it 64kb) for the 27C512 EPROM chip. Or just write the "combined.rom" into 27C256 EPROM.

Very well, I will use the 27C256 then. Do I need to connect the line that says 27C256 on JP4 to any wherr? Or just ignore all of JP4 pins?

Por Wierzbowsky

Guardian (3443)

Imagen del Wierzbowsky

21-05-2022, 12:20

This is just for a jumper. Ignore JP4.

Por alali.ahmed.t

Resident (52)

Imagen del alali.ahmed.t

06-06-2022, 18:00

I managed to see the rom on the test as you can see on the attached picture. I got everything working but with with some noise or little bit weak sound, the yamaha chip I installed first was not working properly, I swapped it got things better but as I said, some noise. I have the capacitors behind the yamaha chip installed. I will remove them and see how it goes.

Another issue I started to have on the carnivore MM app is that I started to see some of folders and files names in red color font as you can see below. I am not sure if that's a problem. Anyone has an idea?

Por alali.ahmed.t

Resident (52)

Imagen del alali.ahmed.t

07-06-2022, 18:30

alali.ahmed.t wrote:

I managed to see the rom on the test as you can see on the attached picture. I got everything working but with with some noise or little bit weak sound, the yamaha chip I installed first was not working properly, I swapped it got things better but as I said, some noise. I have the capacitors behind the yamaha chip installed. I will remove them and see how it goes.

Another issue I started to have on the carnivore MM app is that I started to see some of folders and files names in red color font as you can see below. I am not sure if that's a problem. Anyone has an idea?

I inserted pictures' using google drive link on my previous reply, but the links have not shown up yet. Do I have to use different services to upload the pictures?

Por Wierzbowsky

Guardian (3443)

Imagen del Wierzbowsky

07-06-2022, 19:09

alali.ahmed.t wrote:

I inserted pictures' using google drive link on my previous reply, but the links have not shown up yet. Do I have to use different services to upload the pictures?

https://www.msx.pics/?lang=en

Por alali.ahmed.t

Resident (52)

Imagen del alali.ahmed.t

07-06-2022, 19:20

Thanx Alexey,

Here are the pictures:

https://www.msx.pics/image/yfiBr
https://www.msx.pics/image/ysS8C
https://www.msx.pics/image/ysUTQ

I removed the capacitors behind the yamaha chip and now I have noise of air.

Por alali.ahmed.t

Resident (52)

Imagen del alali.ahmed.t

07-06-2022, 20:15

One more thing, R8 value is 2.2k and installed one but it always read around 0.6k all the time with the multimeter. I thought the resistor was bad, so I changed it and the same reading I got with new resistor. I don’t know if I should put a resistor that would actually read 2.2k with the multimeter even if it higher on the resistor real value!

Por alali.ahmed.t

Resident (52)

Imagen del alali.ahmed.t

23-06-2022, 05:58

I soldered JS3 and that helped to solve the problem of the noise. It is working well now. Thanx a lot Alexey for your help.

Now, I got to find time to continue troubleshooting the faulty keys on the keyboard.

Página 19/19
12 | 13 | 14 | 15 | 16 | 17 | 18 |