Newbie with a B/W Mitsubish ML-F80

Por Mr Lurch

Supporter (2)

Imagen del Mr Lurch

13-05-2022, 04:40

Afternoon all,
Today I have recieved my first MSX, a Mitsubishi ML-F80.
It came to me with the problem of "black screen". Some googling pointed me to the most likely suspect being a bad ROM. So I promptly de soldered the original one, burnt a replacement ([url=http://msx2.org/Funet%20(2006-05-28)/emulator/system_roms/openMSX/Mitsubishi/]link to the one I used[/url]) to a 27c256, soldered in a socket, put the new ROM in and powered it one. It promptly sprang to life... kinda
Both over composite and RF, the picture is Black and white (well, greyscale) Kinda like its getting luminance but no chroma.
I'm not overly familiar with MSX hardware, so I was hoping to find a nudge in the right direction?

Cheers.

Login sesión o register para postear comentarios

Por Manuel

Ascended (18788)

Imagen del Manuel

13-05-2022, 07:33

Which screen are you using?

Por Mr Lurch

Supporter (2)

Imagen del Mr Lurch

13-05-2022, 07:50

On older TEAC flat panel TV I use for all my testing (it supports both NTSC and PAL if thats what you were thinking)
I'm wondering If I have the correct bios tho?
(Im in Australia, so PAL land)

Por Manuel

Ascended (18788)

Imagen del Manuel

13-05-2022, 11:36

The BIOS won't matter. And as far as I know there is only one version of this machine, targeted for pal. (UK)

I guess something is wrong with the analog video circuit...

Por sdsnatcher73

Prophet (3231)

Imagen del sdsnatcher73

13-05-2022, 11:55

I watched this video recently, it is about the repair of 2 SVI-728 computers. The second one actually also had a B/W screen when connected to a CRT. Check at timestamp 15:00, the issue apparently is the video generator's clock being slightly off which causes the screen not to pick up the color information. So adjusting the clock fixed the issue for the SVI-728. Whether the ML-F80 has adjustable resistors in the video circuit.