NMS8280 video problem.

Page 2/2
1 |

By mau_rizio

Resident (49)

mau_rizio's picture

25-12-2010, 18:58

Doing some tests, i've been running Unknown Reality and i noticed that the music in the "notonlysnescandothis" part has some problems.
I made an mp3 so you can clearly hear the speed changes: http://www.freemao.com/ur.mp3
I hope this can help finding the problem.

Merry xmas.
mau

By Eugeny_Brychkov

Paragon (1226)

Eugeny_Brychkov's picture

25-12-2010, 21:27

The speed of the music seems to be controlled by examining VDP's horizontal scanning event bit (bit 0 of status register S#1). So it confirms that there's something wrong with the video subsystem in your PC.
As it was upgraded, I assume V9958 is in the socket. Can you try another chip?
I do not think clearing RTC memory will have any effect, but it can be worth trying... who knows.

PS. Just downloaded and tried UR - cool stuff! I like it very much. It also works on MSX2 (with V9938).

By Eugeny_Brychkov

Paragon (1226)

Eugeny_Brychkov's picture

25-12-2010, 22:12

PS. Just downloaded and tried UR - cool stuff! I like it very much. It also works on MSX2 (with V9938).
But it does not work without RTC chip properly!!! Crying

By mau_rizio

Resident (49)

mau_rizio's picture

25-12-2010, 22:26

The speed of the music seems to be controlled by examining VDP's horizontal scanning event bit (bit 0 of status register S#1). So it confirms that there's something wrong with the video subsystem in your PC.
As it was upgraded, I assume V9958 is in the socket. Can you try another chip?

Unfortunatly the v9958 is not in socket, is soldered on the mb. Anyway don't have another v9958.

I do not think clearing RTC memory will have any effect, but it can be worth trying... who knows.
How can i do this?

PS. Just downloaded and tried UR - cool stuff! I like it very much. It also works on MSX2 (with V9938).
Yes nice stuff Smile it needs 256kb ram and, optional, a music module with 256kb of sample ram.

Thank you.
maurizio

By mau_rizio

Resident (49)

mau_rizio's picture

25-12-2010, 22:55

Where i can find the schematics for installing the 9958 in the 8280?

By mau_rizio

Resident (49)

mau_rizio's picture

26-12-2010, 21:55

Here again Smile
I disassembled the motherborard and on the back i've found this: http://www.freemao.com/msx/v9958back.jpg
What is that?

I've checked all the wires, including those of the 1mb ram expansion, everything seems fine.

Please help :)

By Eugeny_Brychkov

Paragon (1226)

Eugeny_Brychkov's picture

29-12-2010, 09:45

V9958 is pin-compatible with V9938, with some exceptions. What you see is small modification for V9958.
On this picture I can not understand the function of the 1.2K resisor, which is soldered between V9958 pins, in parallel to them. Its one pin is connected to +5v, another one is also connected to this wire... However it seems there should be no contact between this another pin (the resistor net) and +5v wire. Please check.

By mau_rizio

Resident (49)

mau_rizio's picture

29-12-2010, 15:15

Hi Eugeny,
the photo is not very clear but i assure you that everything is connected.
Now i've changed those blu wires, i don't like them. I also delsoldered all those resistors just to find out that nothing is displayed on video but the sound works.
I've also added a wire between pin 20 and 27.
But i find out that the video problems are not related to the mod, but to the analog board.
I swapped the board with another one from a good working 8280 and now the video output is good.
The only thing is irritanting me is that on Unknown Reality the music speed up and the slow down.
I made an mp3: http://www.freemao.com/ur.mp3
If somebody can check this i would be very grateful :)

I've to send a big THANK YOU to Jipe, for the support and patience answering my questions :)

By Eugeny_Brychkov

Paragon (1226)

Eugeny_Brychkov's picture

30-12-2010, 17:18

Does the sound work well on that other good working 8280?

By mau_rizio

Resident (49)

mau_rizio's picture

07-01-2011, 15:39

I can't belevie this... now it's woking good, no more "waves" on screen and no more "fuzzy" music on Unknown Reality...
I'm sure i'm not dreaming cause i have the mp3 of the music and videos of the screen on my phone Smile
I did this:
- I got a phonola 8280, so i get the video board and put in my philips. Video ok but the music still fuzzy.
- But Jipe asked: "this old video board word fine with a V9938 in a other 8280 ?"
- Good question, so i put the "bad" video board into the phonola wich is not modified in any way, and the video is ok... I can test UR because it has just 128k ram.
- So i put back the "bad" board in the philips, and everything is ok.

Please tell me, what the hell is happened? Smile

Page 2/2
1 |