Problemas con Megaflashrom y Mitsubishi ML-G3

Page 1/2
| 2

By Serkun123

Expert (90)

Serkun123's picture

15-03-2022, 10:04

Tengo el Megaflashrom y el Mitsubishi ML-G3 (MSX-2 con 64Kb de RAM, pero con una ampliación en slot interno de 1024Kb).

He borrado una ROM desde el Recovery Mode con F1, pero ahora al iniciar el ordenador con Megaflash me lleva a DOS (o Nextor, puesto que aparece Multimente como directorio (mm)) y aparece el siguiente mensaje:

https://ibb.co/Nn7NR1B

Login or register to post comments

By Guillian

Prophet (3504)

Guillian's picture

15-03-2022, 11:55

¿Y antes de grabar y borrar la ROM te cargaba el MultiMente directamente?

Por la imagen parece que estás en MSX-DOS, no en Nextor. Esto podría deberse a que el ordenador no reconoce tener al menos 128 kB RAM, o el firmware interno (si lo tiene) interfiere en el arranque.

Los mensajes de arranque deberían mostrarte si está cargando Nextor o MSX-DOS.

By Serkun123

Expert (90)

Serkun123's picture

15-03-2022, 14:22

MultiMente sí me lo cargaba normalmente... No sé si estoy en Nextor o MSX-DOS, pero al hacer un dir me salen los subdirectorios mm (MultiMente) y otro más... Lo que no sé es qué comando hay que usar para entrar en un directorio desde Nextor o MSX-DOS... ¿Tenéis alguna idea? Porque lo que parece es que intenta arrancar con mm (en la foto que mando) y eso lo hace directamente el ordenador después de todos los mensajes de arranque. Por otro lado, es un ML-G3, no tiene firmware interno.

By Guillian

Prophet (3504)

Guillian's picture

15-03-2022, 15:01

Para entrar en un directorio tienes que poner CD . P.e.: CD MM
Pero si estás en MSX-DOS ese comando no te va a funcionar. Por eso da error al ejecutarlo desde el AUTOEXEC.BAT

Si puedes pon un vídeo del proceso de arranque para ver qué mensajes salen en pantalla.

Prueba a arrancar pulsado ESC y 0 (cero) por si hubiese algo cargado en el cartucho.

By Serkun123

Expert (90)

Serkun123's picture

15-03-2022, 15:48

Eso mismo pensaba yo, que aunque no ponía el mensaje de que fuera MSX-DOS, tenía toda la pinta, y daba error el AUTOEXEC.BAT, que sería del Nextor. Pero he encontrado la solución instalando kernet.dat desde una MicroSD con formato FAT16 y tamaño de unidad de 32Kb.

By Serkun123

Expert (90)

Serkun123's picture

15-03-2022, 17:23

Ahora el problema es que he tenido que formatear las particiones de una microSD que hasta ahora no había dado problemas. Es una Samsung de 32GB con tantas particiones de 4GB, las he formateado en Fat16 con 16Kb de tamaño de unidad de asignación (sic, en Windows)... No sé si es el tamaño de unidad de asignación adecuado, porque aparecía hasta de 4Kb y 8Kb... El caso es que sigue sin funcionar en el ML-G3, pero mi MSX-2 HB-F9S sí que reconoce la tarjeta, al menos la primera partición -__-'.
Dejo un vídeo del problema en el ML-G3, aunque como veo, el problema es que no reconoce una ram en cartucho de 1024Kb que hay en un slot interno. He probado a ponerla en el slot interno del interfaz RS-232C que trae el ML-G3, pero sigue dando el mismo problema.
Vídeo de ML-G3 con problemas

By Serkun123

Expert (90)

Serkun123's picture

15-03-2022, 17:46

Por las distintas pruebas que voy haciendo, parece que el problema podría estar en la expansión de RAM, que está en un subslot interno y podría no reconocerla. Descarto quizás la posibilidad de que la expansión de RAM esté mal, porque en el ordenador en cuestión, el ML-G3, me ha cargado MultiMente varias veces... No entiendo muy bien porqué, puede que el problema esté en los subslots internos (el ML-G3 tiene un único slot externo y 3 internos).
Mañana haré pruebas y sacaré la RAM para probarla con el HB-F9S y también en el slot 1 (externo) del ML-G3, puesto que este no me ha dejado cargar megaroms desde el disco con la RAM en distintos slots internos.

By Guillian

Prophet (3504)

Guillian's picture

15-03-2022, 21:13

La tarjeta la puedes formatear desde el propio MSX siguiendo estos pasos:

  • Desde línea de comandos ejecuta BASIC. Una vez estés en BASIC teclea CALL FDISK y pulsa RETURN
  • Elige 1 (MegaFlashROM SCC+ SD)
  • Elige 2 (la tarjeta SD)
  • Elige 1 (que probablemente sea la única partición disponible)
  • Pulsa D para borrar la partición
  • Pulsa A para crear una nueva partición
  • Pulsa W para formatear la tarjeta

Pero el problema no está en la tarjeta, sino en la RAM que por alguna razón no te la está reconociendo. El cartucho está arrancando en modo MSX-DOS porque solo encuentra 64 kB RAM.

By Serkun123

Expert (90)

Serkun123's picture

15-03-2022, 21:25

Es Megaflashrom con dos ranuras... Tengo una tarjeta SD de 4GB que compré expresamente, y luego al ver que podía tener MicroSD más grandes con varias particiones, pues compré una de 32GB...

Y edito: ahora que estoy mirando, no me reconoce a partir de la segunda de la de 32GB, lo mismo me estoy equivocando... ¿Cómo debería hacer para formatear en MSX todas las particiones de 4GB que tengo para poder utilizarlas?

By Guillian

Prophet (3504)

Guillian's picture

16-03-2022, 07:58

Serkun123 wrote:

¿Cómo debería hacer para formatear en MSX todas las particiones de 4GB que tengo para poder utilizarlas?

Con el FDISK , mientras haya espacio en la tarjeta y antes de pulsar W, puedes añadir/crear varias particiones de la misma forma que creas la primera.

Para montar el resto de particiones tendrás que usar MAPDRV tras cada arranque, indicado la unidad que quieres usar y la partición a montar. P.e. si el cartucho lo tienes en el slot 1:
MAPDRV e: 2 2 1-3
MAPDRV f: 3 2 1-3
MAPDRV g: 4 2 1-3

By knm1983

Hero (566)

knm1983's picture

17-03-2022, 08:20

Buenas , cuidado con el G3 que lleva un interruptor en la parte trasera que lo que hace es desactivar uno de los slots internos , creo que es el de la parte de arriba del todo, ya que ahí por defecto va la rs232 y se podía activar y desactivar desde ese interruptor , más que nada por si tienes la ampliación en ese slot y por alguna casualidad se ha tocado el interruptor trasero y está la ram desactivada.

Page 1/2
| 2