1ChipMSX: DSK files corrupted by the COPY command

Страница 1/2
| 2

By vanfanel

Champion (446)

Аватар пользователя vanfanel

13-03-2011, 13:55

Hello there

I'm having a strange problems I've been trying to deal with with my housemade 1chipMSX.
The COPY command seems to corrupt the DSK files: if I use it to copy a DSK, the resulting file is UNUSABLE with EP.COM ("illegal FAT chain" error).

I'm using the MSX2+ BIOS + CORE , the computer behaves in fact like an MSX2+.
I'm using a FAT16-formatted PANASONIC 1GB SD card as hardisk. I've tried to format from Windows with the Panasonic formatter, manual frmat command with appropiate parameters, etc. I've also formatted it from MAC OSX and from inux with the mkfs.vfat tool. No Differences. I always end having the same problem!
The MSX-DOS version I'm using is 2.42, but it says "msx-dos 2.30" at boot anyway.

Appart frm this issue, the system runs fine and EP.COM and ROMLOAD.COM make a great job, but I need to fix this one.

Thanks!

Для того, чтобы оставить комментарий, необходимо регистрация или !login

By vanfanel

Champion (446)

Аватар пользователя vanfanel

17-03-2011, 15:47

Hmmm.. Are you guys sure that you don't have an idea about what causing COPY to result on broken DSK files?

By luppie

Paladin (864)

Аватар пользователя luppie

17-03-2011, 21:34

Have you already tried RUNIT to use a copied diskimage ?
Try it and tell us the result.

By msd

Paragon (1472)

Аватар пользователя msd

17-03-2011, 22:14

What and how do you copy it?

By Imanok

Paragon (1192)

Аватар пользователя Imanok

17-03-2011, 22:20

Have you tried to use the new DSK you copied on a PC to see if it's really corrupted??

As far as I remember, EP.COM had problems reading DSK's not secuentially saved on disk (and this could be related to the COPY command under FAT16)

By NYYRIKKI

Enlighted (5939)

Аватар пользователя NYYRIKKI

18-03-2011, 08:19

I've had also problems copying pretty much anything from Sunrise CF to SD card... There is something wrong with OCM file system, but I don't know what.

By vanfanel

Champion (446)

Аватар пользователя vanfanel

19-03-2011, 01:56

@all: it seems the files aren't really corrupted. I tried copying them to my Linux system, then formating the card again and then copying the files back and they were useable.

Runit.com does a damn fine job for running ys, along with it's user disk to save / load the game. It uses concatenated files so it doesn't have to face problems with sequential files Big smile
It seems non-sequential files were the problem after all! Thanks, Imanok!!

Anyway, Ys tends to hang in TURBO mode with both EP.COM and RUNIT.COM. And it's sooooo slow in 3 MHz mode...
If only this game would be playable from HD somehow... but souch a thing is impossible, as far as I know.

By boss_msx

Champion (415)

Аватар пользователя boss_msx

09-08-2013, 00:14

I'm looking for EP.COM but it's no where to be found on the WWW. Can anyone tell me where I can find it? oO

By KdL

Paragon (1434)

Аватар пользователя KdL

09-08-2013, 08:14

@vanfanel: it may be a bug using the keyboard during the copy process. Could you try?

By boss_msx

Champion (415)

Аватар пользователя boss_msx

09-08-2013, 08:52

His post is more than 2 years old LOL!

And I'm no longer searching for the file!

By Jipe

Paragon (1552)

Аватар пользователя Jipe

09-08-2013, 10:09

Страница 1/2
| 2